`
wangqisen
  • 浏览: 47072 次
文章分类
社区版块
存档分类
最新评论

暴搜之1980 Unit Fraction Partition

 
阅读更多
Unit Fraction Partition
Time Limit:1000MS Memory Limit:30000K
Total Submissions:3824 Accepted:1500

Description

A fraction whose numerator is 1 and whose denominator is a positive integer is called a unit fraction. A representation of a positive rational number p/q as the sum of finitely many unit fractions is called a partition of p/q into unit fractions. For example, 1/2 + 1/6 is a partition of 2/3 into unit fractions. The difference in the order of addition is disregarded. For example, we do not distinguish 1/6 + 1/2 from 1/2 + 1/6.

For given four positive integers p, q, a, and n, count the number of partitions of p/q into unit fractions satisfying the following two conditions.

The partition is the sum of at most n many unit fractions.
The product of the denominators of the unit fractions in the partition is less than or equal to a.
For example, if (p,q,a,n) = (2,3,120,3), you should report 4 since

enumerates all of the valid partitions.

Input

The input is a sequence of at most 200 data sets followed by a terminator.

A data set is a line containing four positive integers p, q, a, and n satisfying p,q <= 800, a <= 12000 and n <= 7. The integers are separated by a space.

The terminator is composed of just one line which contains four zeros separated by a space. It is not a part of the input data but a mark for the end of the input.

Output

The output should be composed of lines each of which contains a single integer. No other characters should appear in the output.

The output integer corresponding to a data set p, q, a, n should be the number of all partitions of p/q into at most n many unit fractions such that the product of the denominators of the unit fractions is less than or equal to a.

Sample Input

2 3 120 3
2 3 300 3
2 3 299 3
2 3 12 3
2 3 12000 7
54 795 12000 7
2 3 300 1
2 1 200 5
2 4 54 2
0 0 0 0

Sample Output

4
7
6
2
42
1
0
9
3

Source


#include<iostream>
#include<cmath>
using namespace std;
double E=0.0000000001;
int counter=0,N,A;
int dfs2(double sum,int num,int product,int t){
	if(t>N||product>A||(sum<0&&abs(sum)>=E))
		return 0;
	if(abs(sum)<E){
		counter++;
		return 1;
	}
	for(int i=num;;i++){
		if(1.0/i*(N-t)<sum)
			break;
		else{
			dfs2(sum-1.0/i,i,i*product,t+1);
		}
	}
	return 1;
}
int main(){
	int p,q,a,n;
	while(true){
		cin>>p>>q>>A>>N;
		dfs2(p*1.0/q,2,1,0);
		cout<<counter<<endl;
	}
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics