`
wangqisen
  • 浏览: 47002 次
文章分类
社区版块
存档分类
最新评论

1018 Communication System

 
阅读更多
Communication System
Time Limit:1000MS Memory Limit:10000K
Total Submissions:21187 Accepted:7524

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649
#include<iostream>
using namespace std;
int v[101][101][3];
int l[101];
int minB(){
	int min=10000,index=0;
	for(int i=1;i<101;i++){
		for(int j=1;j<101;j++){
			if(v[i][j][2]&&v[i][j][0]<min){
				min=v[i][j][0];
			}
		}
	}
	return min;
}
int getMax(int n[][3],int l,int P){
	int maxJ=1;
	double r=0;
	for(int i=1;i<=l;i++){
		int B1;
		if(n[i][0]>minB())
			B1=minB();
		else
			B1=n[i][0];
		int P1=P+n[i][1];
		if(B1*1.0/P1>r){
			r=B1*1.0/P1;
			maxJ=i;
		}
	}
	return maxJ;
}
int main(){
	int m,B=0,P=0;
	cin>>m;
	for(int i=1;i<101;i++)
		for(int j=1;j<101;j++)
			for(int k=0;k<=2;k++)
				v[i][j][k]=0;
	for(int i=1;i<=m;i++){
		cin>>l[i];
		for(int j=1;j<=l[i];j++)
			cin>>v[i][j][0]>>v[i][j][1];
	}

	for(int i=1;i<=m;i++){
		int t=getMax(v[i],l[i],P);
		P+=v[i][t][1];
		v[i][t][2]=1;
	}
	cout<<minB()*1.0/P<<endl;
	system("pause");
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics