`
wangqisen
  • 浏览: 46472 次
文章分类
社区版块
存档分类
最新评论

搜索或者动态规划均可做之1015 Jury Compromise

 
阅读更多
Jury Compromise
Time Limit:1000MS Memory Limit:65536K
Total Submissions:23478 Accepted:6080 Special Judge

Description

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury.
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties.
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution.
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties.
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.

Input

The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members.
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next.
The file ends with a round that has n = m = 0.

Output

For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.).
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number.
Output an empty line after each test case.

Sample Input

4 2 
1 2 
2 3 
4 1 
6 2 
0 0 

Sample Output

Jury #1 
Best jury has value 6 for prosecution and value 4 for defence: 
 2 3 
#include<iostream>
using namespace std;
#define NMAX 200
int V[NMAX][2];
int MARR[25];
int N,M,mD,mP;
int MIN;
void dfs(int i,int m,int value,int valueD,int valueP){
	if(m==M){
		if(value<MIN){
			MIN=value;
			mD=valueD;
			mP=valueP;
		}else if(value==MIN&&valueD+valueP>mD+mP){
			mD=valueD;
			mP=valueP;
		}
		return;
	}
	int d=valueD+V[i][0];
	int p=valueP+V[i][1];
	int v=abs(d-p);
	MARR[i]=1;
	for(int j=1;j<=N;j++){
		if(!MARR[j]){
			dfs(j,m+1,v,d,p);
		}
	}
	MARR[i]=0;
}
int main(){
	MIN=25;
	int i;
	cin>>N>>M;
	for(i=0;i<25;i++)
		MARR[i]=0;
	for(i=1;i<=N;i++)
		cin>>V[i][0]>>V[i][1];
	for(i=1;i<=N;i++)
		dfs(i,0,0,0,0);
	cout<<MIN<<mD<<mP<<endl;
	for(i=1;i<=N;i++)
		cout<<MARR[i];
}
//动态规划部分
#include<iostream>
using namespace std;
int n,m;
int dp[21][801],path[21][801];
bool select(int j,int k,int i,int*v){
	while(j>0&&path[j][k]!=i){
		k-=v[path[j][k]];
		j--;
	}
	return j>0?false:true;
}
int main(){
	cin>>n>>m;
	int* p=new int[n+1];  //每个人的控方值  
	int* d=new int[n+1];  //每个人的辩方值  
	int* s=new int[n+1];  //每个人的辨控和  
    int* v=new int[n+1];  //每个人的辨控差  
	for(int i=1;i<=n;i++){
		cin>>p[i]>>d[i];
		s[i]=p[i]+d[i];
		v[i]=p[i]-d[i];
	}
	memset(dp,-1,sizeof(dp));  
	memset(path,0,sizeof(path));
	int fix=m*20;
	dp[0][fix]=0;
	for(int j=1;j<=m;j++){
		for(int k=0;k<=2*fix;k++){
			if(dp[j-1][k]>=0){
				for(int i=1;i<=n;i++){
					if(select(j-1,k,i,v)){
						if(dp[j][k+v[i]]<dp[j-1][k]+s[i]){
							dp[j][k+v[i]]=dp[j-1][k]+s[i];
							path[j][k+v[i]]=i;
						}
					}
				}
			}
		}
	}
	for(int k=0;k<=fix;k++){
		if(dp[m][fix-k]>=0||dp[m][fix+k]>=0)
			break;
	}
	int div=dp[m][fix-k]>dp[m][fix+k]?(fix-k):(fix+k);
	cout<<(dp[m][div]+div-fix)/2<<" for prosecution and value ";  
	//控方总值 = (辨控和-辨控差+修正值)/2  
    cout<<(dp[m][div]-div+fix)/2<<" for defence:"<<endl;  
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics